Prerequisites

Supported operating systems, packages, and hardware configurations

The following sections describe the operating systems, software packages and hardware configurations required to run Dispatch.

Supported operating systems

Prerequisites for installation on Konvoy

If you will be installing Dispatch on Konvoy, be aware that Konvoy supports only the following operating systems:

CentOS

OS Release Kernel Version
CentOS 7.6 3.10.0-957

RHEL

OS Release Kernel Version
RHEL 7.6 3.10.0-957

Ubuntu

OS Release Kernel Version
Ubuntu 16.04 (xenial) 4.4.0-1087

Debian

OS Release Kernel Version
Debian 9 (stretch) 4.9.0-9
Debian 10 (buster) 4.19.67-2

Supported software packages

These are the software package versions that Dispatch supports.

On Konvoy

If you will be installing Dispatch on Konvoy, be aware that Konvoy supports only the following versions of our supported software:

Package Version Description
Kubernetes Container orchestration manager
Prometheus An open-source monitoring system
Tiller 2.14.2 or later
Traefik Open source edge router
Helm 2 Package manager for Kubernetes

For more details, see the Konvoy documentation.

Supported hardware configurations

Dispatch requires the following resources to be available in the cluster:

  • CPU: 4 cores
  • Mem: 4GiB RAM
  • Disk: 50GiB of persistent disk Dispatch is tested and known to work with Konvoy v1.4.0, with m5.2xlarge AWS EC2 instances.

Additional resources may be required depending on the size, complexity and number of pipelines that are being processed by Dispatch.