Supported Operating Systems

Supported operating systems for Konvoy

Konvoy supports the following base Operating Systems.

Amazon Web Services (AWS)

Operating System Kernel Default Config FIPS Air Gapped FIPS with Air Gapped GPU Support
CentOS 7.9 3.10.0-1160.el7.x86_64 Yes Yes Yes Yes Yes
RHEL 7.9 3.10.0-1160.el7.x86_64 Yes Yes Yes Yes
RHEL 8.2 4.18.0-193.6.3.el8_2.x86_64 Yes Yes Yes Yes
RHEL 8.4 4.18.0-305.el8.x86_64 Yes Yes Yes Yes
Ubuntu 18.04 (Bionic Beaver) Yes
Ubuntu 20.04 (Focal Fossa) Yes Yes
SLES 15 SP3 Yes Yes Yes
Oracle Linux RHCK 7.9 kernel-3.10.0-1160.el7 Yes Yes

Pre-Provisioned/On Premises

Operating System Kernel Default Config FIPS Air Gapped FIPS with Air Gapped GPU Support
CentOS 7.9 3.10.0-1160.el7.x86_64 Yes Yes Yes
RHEL 7.9 3.10.0-1160.el7.x86_64 Yes Yes
RHEL 8.4 4.18.0-305.el8.x86_64 Yes Yes
Flatcar 3033.2.x Yes
SLES 15 SP3 Yes
Oracle Linux RHCK 7.9 kernel-3.10.0-1160.el7 Yes

vSphere

Operating System Kernel Default Config FIPS Air Gapped FIPS with Air Gapped GPU Support
CentOS 7.9 3.10.0-1160.el7.x86_64 Yes
RHEL 7.9 3.10.0-1160.el7.x86_64 Yes Yes Yes Yes
RHEL 8.4 4.18.0-305.el8.x86_64 Yes Yes Yes Yes

Azure

Operating System Kernel Default Config FIPS Air Gapped FIPS with Air Gapped GPU Support
Ubuntu 20.04 (Focal Fossa) Yes

EKS

Operating System Kernel Default Config FIPS Air Gapped FIPS with Air Gapped GPU Support
Amazon Linux 2 Yes

AKS

Operating System Kernel Default Config FIPS Air Gapped FIPS with Air Gapped GPU Support
Ubuntu 18.04 (Bionic Beaver) Yes