Prerequisites

Fulfill the prerequisites for using a pre-provisioned infrastructure

Before you begin using Konvoy, you must have:

  • An x86_64-based Linux or macOS machine.
  • The dkp binary for Linux, or macOS.
  • [Docker][install_docker] version 18.09.2 or later installed.
  • [kubectl][install_kubectl] for interacting with the running cluster.
  • Pre-provisioned hosts with SSH access enabled.
  • An unencrypted SSH private key, whose public key is configured on the above hosts.

When these prerequisites are in place, you can prepare your hosts.