Skip to main content
Skip table of contents

Upgrade Compatibility Tables

The latest DKP versions for Kubernetes, applications, and components are available on this page. Individual sections will have links to pages with further information if required.

Supported Operating Systems

The supported Operating System (OS) is important for upgrades. During an upgrade, you would need to create new AMI’s or images with the Kubernetes version to which you want to upgrade. That requires selecting an OS and ensuring you have the right version. Check the Supported Infrastructure Operating Systems page if you have not already done so.

Konvoy Image Builder

Refer to the main page for a table of components versions and compatibility.

Kubernetes Version Supported

These are the supported versions:

Deploying Clusters Versions

The latest supported Kubernetes versions for DKP are listed below. In DKP 2.6.2, the Kubernetes version installed by default is 1.26.14. The newest and oldest Kubernetes versions used with DKP must be within one minor version.

  • Latest supported Kubernetes version is at 1.26.14 for deploying clusters

  • Other Kubernetes versions are supported at 1.25.13 for deploying clusters in EKS

Kubernetes 1.26.14 enables you to benefit from the latest features and security fixes in upstream Kubernetes. This release comes with approximately 40 enhancements that you can benefit from like Service internal tracking policy, Kubelet credential provider, among others. To read more about major features in this release, visit GitHub and

Attaching Clusters Versions

DKP 2.6.2 supports attaching clusters with the following Kubernetes versions:


Compatible Kubernetes Versions







Attaching Kubernetes clusters with versions greater than n-1 is not recommended.

When attempting to attach a cluster with a lower Kubernetes version than the DKP default, you need to build and use an image with that lower version of Kubernetes. See Konvoy Image Builder for documentation on building images. Failure to do this could result in an error.

Next Step:

Upgrade Prerequisites

JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.