The newest and oldest Kubernetes versions used with DKP must be within one minor version. For example:

  • newest supported Kubernetes version is at 1.24.6

  • other Kubernetes versions are supported at 1.23.x

Note: DKP 2.4 comes with support for Kubernetes 1.24.6, enabling you to benefit from the latest features and security fixes in upstream Kubernetes. This release comes with approximately 46 enhancements. To read more about major features in this release, visit https://kubernetes.io/blog/2022/05/03/kubernetes-1-24-release-announcement/.

Attaching Clusters Versions

DKP 2.5.0 supports attaching clusters with the following Kubernetes versions:

Product

Compatible Kubernetes Versions

EKS

1.23.x

AKS

1.24.x

GKE

1.24.x