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DKP Insight Alerts

A detected DKP Insight Alert persists for 72 hours. If an existing Insight Alert is not updated in that period, it expires and is removed from the table. If the anomaly recurs, the Insight Alert reappears in the table.

After the DKP Insights Engine is enabled in a Managed or Attached cluster, select a workspace in the DKP UI that includes the cluster to view the DKP Insight Alerts. An Insights summary card in the Dashboard tab displays the most recent Insight Alerts, as well as the number of insights within each severity level of Critical, Warning, and Notices.

Select View All from the Insights summary card or Insights from the sidebar to access the DKP Insight Alert table. This table provides an overview of all the Insight Alerts. You can filter these Insight Alerts in several different ways:

  • Use the search dialog to search by description keyword.

  • View by status:
    Note: Muted and Resolved status are manually set, as described below.

    • Open

    • Muted

    • Resolved

  • Toggle your view by the following insight types:

    • All types

    • Availability

    • Best Practices

    • Configuration

    • Cost

    • Environment

    • Performance

    • Security

    • Upgrade

  • Select All Clusters or an individual cluster.

  • Select All Projects or an individual project.

  • Toggle between All, Critical, Warning, and Notices.

To clear filters and reset your view to all Insight items, select Clear All.

Resolve or Mute Alerts

To resolve or mute a single or multiple alerts:

When you resolve an alert, it is not possible to move it back to Open or Muted. Ensure you only resolve alerts once you fix the issue.

  1. From the Insight Alert table, filter and check the boxes for the alerts in question.

  2. From the top of the Insight Alert table, select:

    • Resolved if you have resolved the issues or

    • Mute if you want to silence the alert

  3. A confirmation prompt for the status change appears once you resolve or mute an Insight Alert.

View Resolved or Muted Alerts

Once you set an alert to Resolved or Muted, it does not appear in the Open Insight Alert table view.

To view Resolved or Muted Alerts:

  1. From the Insight Alert table, select the drop-down arrow and the appropriate filter:

Insight Alert Usage Tips

  • For an Insight Alert you do not want to use, check the box corresponding to that alert and select Mute. This only silences the individual Insight Alert. If the anomaly recurs, the Insight remains muted, but the Last Detected timestamp is updated.

DKP Insight Alert Details

From the DKP Insight Alert table, select the Details link to view additional information.

The common sections that alerts contain are:

  • Severity

  • Last Detected

  • Description

  • Types

  • Cluster

  • Project, if applicable

Root Cause Analysis

This section provides all the necessary information you need to understand the root cause of the anomaly.

Solutions

This section contains recommended steps to resolve the anomaly.

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